반응형
Notice
Recent Posts
Recent Comments
Link
일 | 월 | 화 | 수 | 목 | 금 | 토 |
---|---|---|---|---|---|---|
1 | 2 | 3 | 4 | 5 | 6 | 7 |
8 | 9 | 10 | 11 | 12 | 13 | 14 |
15 | 16 | 17 | 18 | 19 | 20 | 21 |
22 | 23 | 24 | 25 | 26 | 27 | 28 |
29 | 30 | 31 |
Tags
- 연산 프로퍼티
- 진입점
- UIButton
- 트레일링 클로저
- Understanding Swift Performance
- Remot Push
- 원격 푸시
- OperationQueue
- DispatchQueue
- RunLoop
- CoreLocation
- for-in
- SWiFT
- weak
- AppTransportSecurity
- Choosing Between Structures and Classes
- uikit
- IBOutletCollection
- tableViewCell
- WWDC16
- TableView
- property wrapper
- userdefaults
- ios
- IBOutlet
- entrypoint
- 동시성프로그래밍
- viewcontroller
- firebase
- 후행 클로저
Archives
- Today
- Total
iOS 공부하는 감자
백준 1920 본문
반응형
수 찾기 성공
시간 제한메모리 제한제출정답맞힌 사람정답 비율
1 초 | 128 MB | 118551 | 35285 | 23309 | 30.066% |
문제
N개의 정수 A[1], A[2], …, A[N]이 주어져 있을 때, 이 안에 X라는 정수가 존재하는지 알아내는 프로그램을 작성하시오.
입력
첫째 줄에 자연수 N(1 ≤ N ≤ 100,000)이 주어진다. 다음 줄에는 N개의 정수 A[1], A[2], …, A[N]이 주어진다. 다음 줄에는 M(1 ≤ M ≤ 100,000)이 주어진다. 다음 줄에는 M개의 수들이 주어지는데, 이 수들이 A안에 존재하는지 알아내면 된다. 모든 정수의 범위는 -231 보다 크거나 같고 231보다 작다.
출력
M개의 줄에 답을 출력한다. 존재하면 1을, 존재하지 않으면 0을 출력한다.
예제 입력 1 복사
5
4 1 5 2 3
5
1 3 7 9 5
예제 출력 1 복사
1
1
0
0
1
내 풀이
1. 이진검색을 사용한 풀이 (시간초과)
func binarySearch(sortedList: [Int], item: Int) -> Int {
if sortedList.count == 1 {
return item == sortedList[0] ? 1 : 0
}
let midIndex: Int = sortedList.count / 2
let range: Range<Int> = item < sortedList[midIndex] ? (0..<midIndex) : (midIndex..<sortedList.count)
return binarySearch(sortedList: [Int](sortedList[range]), item: item)
}
let aCount: Int = Int(readLine()!)!
var aArray: [Int] = readLine()!.split(separator: " ").map({Int($0)!}).sorted()
let mCount: Int = Int(readLine()!)!
var mArray: [Int] = readLine()!.split(separator: " ").map({Int($0)!})
for num in mArray {
print(binarySearch(sortedList: aArray, item: num))
}
2. Set으로 변환하여 풀이 (성공)
let aCount: Int = Int(readLine()!)!
var aSet: Set<Int> = Set(readLine()!.split(separator: " ").map({Int($0)!}))
let mCount: Int = Int(readLine()!)!
var mArray: [Int] = readLine()!.split(separator: " ").map({Int($0)!})
for num in mArray {
print(aSet.contains(num) ? 1 : 0)
}
Set 타입에서 contain()메서드는 시간복잡도 O(1)
반응형